Páginas novas
- 12h36min de 27 de janeiro de 2020 Functions Should Do One Thing (his) [103 bytes] Admin (discussão | contribs) (Criou página com 'FUNCTIONS SHOULD DO ONE THING. THEY SHOULD DO IT WELL. THEY SHOULD DO IT ONLY Category: Clean Code')
- 12h33min de 27 de janeiro de 2020 Functions Should Be Small (his) [2 676 bytes] Admin (discussão | contribs) (Criou página com 'The first rule of functions is that they should be small. The second rule of functions is that they should be smaller than that. This is not an assertion that I can justify. I...')
- 12h25min de 27 de janeiro de 2020 Method Names (his) [749 bytes] Admin (discussão | contribs) (Criou página com 'Methods should have verb or verb phrase names like postPayment, deletePage, or save. Accessors, mutators, and predicates should be named for their value and prefixed with get,...')
- 12h22min de 27 de janeiro de 2020 Class Names (his) [293 bytes] Admin (discussão | contribs) (Criou página com 'Classes and objects should have noun or noun phrase names like '''Customer''', '''WikiPage''', '''Account''', and '''AddressParser'''. Avoid words like '''Manager''', '''Proce...')
- 12h19min de 27 de janeiro de 2020 Interfaces and Implementations (his) [797 bytes] Admin (discussão | contribs) (Criou página com 'These are sometimes a special case for encodings. For example, say you are building an ABSTRACT FACTORY for the creation of shapes. This factory will be an interface and will...')
- 12h17min de 27 de janeiro de 2020 Don't Use Member Prefixes (his) [620 bytes] Admin (discussão | contribs) (Criou página com 'You also don’t need to prefix member variables with m_ anymore. Your classes and functions should be small enough that you don’t need them. And you should be using an edit...')
- 12h09min de 27 de janeiro de 2020 Avoid encodings: Hungarian Notation (his) [3 113 bytes] Admin (discussão | contribs) (Criou página com 'Examples of Hungarian Notation: * lAccountNum : variable is a long integer ("l"); * arru8NumberList : variable is an array of unsigned 8-bit integers ("arru8"); * bReadLine(b...')
- 11h52min de 27 de janeiro de 2020 Use Searchable Names (his) [1 612 bytes] Admin (discussão | contribs) (Criou página com 'Single-letter names and numeric constants have a particular problem in that they are not easy to locate across a body of text. One might easily grep for MAX_CLASSES_PER_STUDE...')
- 11h45min de 27 de janeiro de 2020 Use Pronounceable Names (his) [1 689 bytes] Admin (discussão | contribs) (Criou página com 'Humans are good at words. A significant part of our brains is dedicated to the concept of words. And words are, by definition, pronounceable. It would be a shame not to take a...')
- 11h31min de 27 de janeiro de 2020 Use Intent Revealing Names (his) [3 615 bytes] Admin (discussão | contribs) (Criou página com 'It is easy to say that names should reveal intent. What we want to impress upon you is that we are serious about this. Choosing good names takes time but saves more than it ta...')
- 11h30min de 27 de janeiro de 2020 Clean Code (his) [3 226 bytes] Admin (discussão | contribs) (Criou página com '* Use Intent Revealing Names Category:Clean Code')
- 10h41min de 27 de janeiro de 2020 Angular (his) [730 bytes] Admin (discussão | contribs) (Criou página com '* Creating a new class * Creating a new component * Creating a new directive * Creating a new project * Creating a new project with Sass * Creating a new...')